Majid Rana

Engine M119 S500 1998 engine die at 1500-2000 RPM when cold

Recommended Posts

Im Having Mercedes S500 1998 W140 Engine 119

When i start my car after 7-8 hours engine starts fine no missing no stalling but when i put in gear and start acceleration as the RPM reaches 1500-2000 the engine starts missing and stalling and if i dont remove my feet from pedal the engine would DIE / OFF due to which i have to start it again and this missing/ stalling is only when RPM crosses 1500-2000 other wise in idle situation engine is smooth and  after 15-20 minutes of driving in that slow RPM engine automatically get fine and it starts accelerating well.my car is in  that situation since 5-6 months

Share this post


Link to post
Share on other sites

Dear Majid ,

when was your last service done ? and what was actually done at that service?

do you have a record of regular service details?

with kind regards

Share this post


Link to post
Share on other sites

I suspect few things to doubt that you might not be using correct grade of engine oil as suggested by Mercedes. It's also worth double checking the spark plug specifications and you might not be using colder plug that take sometime to warm and become normal thereafter. 

Share this post


Link to post
Share on other sites

I meant what was the regular service were fuel filter etc and plugs changed on time or not. These details might give a little clue about situation.

I have a bluetooth scanner if you want we can check your codes as well.

Kind regards

Share this post


Link to post
Share on other sites

yes i changed fuel filter , spark plugs , air filter, fuel pump in march 2016 and my car had made a run of 20000 - 25000 kilometer only

 

Mr.AK where u live ? yes i would like to have scan for my car to diagnose this problem

Share this post


Link to post
Share on other sites
On 04/12/2016 at 3:56 PM, Rahimdad said:

Congrats AK, nice friend, lucky you. Might just want to be friends with your friends, I want such gifts too.

 

1 minute ago, Majid Rana said:

yes i changed fuel filter , spark plugs , air filter, fuel pump in march 2016 and my car had made a run of 20000 - 25000 kilometer only

 

Mr.AK where u live ? yes i would like to have scan for my car to diagnose this problem

I live in dubai al nahda 1 . If u r free tomorow evening we can check it. Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now