sertac

Cherokee XJ Immobilizer problem

Recommended Posts

cherokees have a very delicate electronic system any sensor or actuator giving out of spec readings will trigger the no bus message and some times all hell unleashed on the electronics...as its a bus system

Share this post


Link to post
Share on other sites

@sertac did you get it fixed? Was it a coil issue?

Share this post


Link to post
Share on other sites
9 hours ago, Barry said:

@sertac did you get it fixed? Was it a coil issue?

I went Mohsin to check it. They connect it to computer and fuel injector connection was the problem. They fixed the injectors properly and put some silicon to keep them tight. After that check engine light, shaking and power loss was gone. I was happy to solve it that easy but yesterday when i was off roading key ignition light, check engine light, no bus erorr came on speedometer and rev came 0. When i shut off the engine it didnt start again like before. I opened the hood remove the coil pack and put it back. After that car start again and all lights and warnings gone. I think i still need coil pack.  

Share this post


Link to post
Share on other sites
1 hour ago, desertdude said:

I know this is very logical. What i dont understand is why when i remove the coil pack and put it back again everything became good. What is the connection between gauge and coil pack?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now