kumara

ECU of my Ford Escape 2009

Recommended Posts

Hi all,

I have a problem on my Ford Escape. One fine day about 4 week back, when I start moving after Traffic Signal become green, dashboard started showing HandBrake light, ABS light and Traction controls lights on all the time.

I then took it to a known Garage, they checked and said, sensors are all fine, but could be a problem of Car ECU. New ECU is very costly at the Agency. Anybody there to give me an expert advise?

Thanks a lot!

Happy driving...!

Share this post


Link to post
Share on other sites

Good afternoon, 

I would not buy another ECU as this problem may be a switch or sensor that links the three circuits/systems. Look at finding a wiring diagram to source and fix the issue

Regards, Richard

Share this post


Link to post
Share on other sites

Richard is right- this is very unlikely to involve the ECU. Best thing to do is to have a diagnostic scan done to get the codes.  

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for advices.

Doyou know a good garage to go specialize in Ford vehicles?

Share this post


Link to post
Share on other sites
7 hours ago, kumara said:

Thanks for advices.

Doyou know a good garage to go specialize in Ford vehicles?

See if you can contact @Barry through the forum here, and twist his arm to run a diagnostic for you. He has a professional-grade computer, and he know how to use it, so he might be your best bet. 

  • Like 1

Share this post


Link to post
Share on other sites

There are so many General service workshop listed from Dubai in Carnity Business listing section. They all provide special pricing and honest service for Carnity members, select any which is close to your area like in Rashidiya, Al Quoz, Aweer, Deira etc. and get the OBD Scan to get the codes (max 100 dhs). And come back and let us know the exact codes so that experts can advise you the next course of action.

I seriously think your known garage is not well equipped to advise you in the right direction, as ECU failure is one in 10,000 and more often some of the sensor, wiring or connector fails that throw some error so that you can debug in the right direction. And due to this sensor or connector failure, all light comes up at the same time.

https://carnity.com/business_listing/car-services/general-service-workshop/?advanced_search_submitted=1&csrfKey=88a330f554c7c70fb7391466ab9d93c7&content_field_30[1]=Dubai&sortby=primary_id_field&sortdirection=desc&record_type=all&time_frame=show_all

 

Share this post


Link to post
Share on other sites

Need to check the steering angle sensor and wheel speed sensors and associated wiring as these could cause that particular combination of lights to come on. There’s also a possibility of faulty dash clocks or wiring to the dash clocks, or a loose connection somewhere in the ignition loom. ECU is unlikely to be faulty and it’s an expensive part to throw at it without a proper diagnosis. Find a better garage. 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks a lot for all your advice. I went to a garage in Sharjah, near Hyper Ramez on SMBZ Road. They fixed it. 

Share this post


Link to post
Share on other sites
2 hours ago, kumara said:

Thanks a lot for all your advice. I went to a garage in Sharjah, near Hyper Ramez on SMBZ Road. They fixed it. 

Great!

Share this post


Link to post
Share on other sites

So what was the problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now