Sign in to follow this  
bradt

hazard and indicator issue. that confuses me

Recommended Posts

sometime the indicator works sometimes it wont. sometime hazard light works sometimes it wont sometimes both work and sometimes both wont work at the same time.

can anyone tell me what is this please.

Share this post


Link to post
Share on other sites

there maybe some problem with the fuses or the connection. if the bulbs were failing then they wouldn't even glow so it cat be the blubs.

Share this post


Link to post
Share on other sites

Have you figured it out. it definetly looks like wiring problem. You can go to garage's listed in Sharjah General purpose workshop in home page in sharjah industrial area and see a good electrician.

Share this post


Link to post
Share on other sites

few years back when i owned toyota corolla i faced same problem and after spending 2K i had to find out the hard way that it was an electrical problem.

Share this post


Link to post
Share on other sites

harry wrote:

> few years back when i owned toyota corolla i faced same problem and after

> spending 2K i had to find out the hard way that it was an electrical

> problem.

after spending the cash did you have the same problem.

Usually lexus is not very famous for electrical problem and lexus is a part of toyota.

Share this post


Link to post
Share on other sites

jay wrote:

> there maybe some problem with the fuses or the connection. if the bulbs

> were failing then they wouldn't even glow so it cat be the blubs.

yeah jay it was connection that was getting fused.

great help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this